SKU: 66776215827

Tenda A9 Wireless N300 Universal WiFi Range Extender (UK Plug)

Sale price$9.86 Regular price$10.96
Save 10%

Pay in installments of $2.74 with ShopPay, AfterPay and Klarna

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 30 - Nov 4

Promo Codes Available:

For Your Every Summer RSVP, with Code: SUMMER15

Description

Tenda A9 Wireless N300 Universal WiFi Range Extender (UK Plug)A9 is a wireless N300 universal range extender, specially designed to extend the exisiting WiFi coverage and improve the signal strength. With one button extension, smart signal LED, wall mount design and universal compatibility, it is easy for users to boost wireless networking. A9 is an ideal choice for you to eliminate WiFi dead zones and optimize your networking. 300 Mbps 802. 11n speed. 2 x 3 dBi external antennas boost signal to extend WiFi

A9 is a wireless N300 universal range extender, specially designed to extend the exisiting WiFi coverage and improve the signal strength. With one button extension, smart signal LED, wall-mount design and universal compatibility, it is easy for users to boost wireless networking. A9 is an ideal choice for you to eliminate WiFi dead zones and optimize your networking.

• 300 Mbps 802.11n speed.
• 2 x 3 dBi external antennas boost signal to extend WiFi coverage up to more 200m.
• One button extension help to extend WiFi coverage easily.
• Smart WiFi Signal Strength LED help to choose optimum location easily.
• Compatible with main brands 802.11n standard wireless routers and WiFi DSL.
• Support SSID Hiding


Standards & Protocol
IEEE802.11b,IEEE 802.11g, IEEE 802.11n

Interface
None

Buttons
None

Power Consumption
N/A

Antennas
2 x 3dBi external non-detachable

Frequency
2.412GHz - 2.484GHz

Data/Signal Rate
802.11b: 11Mbps
802.11g: 54Mbps
802.11n: 300Mbps

Reception Sensitivity
11b: -95dBm
11g: -76dBm
11n: -73dBm

802.11b: DSSS / BPSK / QPSK / CCK
802.11g: OFDM / DSSS / BPSK / QPSK / CCK
802.11n: OFDM / DSSS / BPSK / QPSK / CCK

Wireless Modes
Range Extender
Repeater Mode (Client + AP)

Wireless Functions
RFC768 UDP
RFC791 IP
RFC792 ICMP
RFC793 TCP
Channel Bandwidth: 20/40MHz (default)

Wireless Security
Encryption Mode: Mix WPA-PSK/WPA2-PSK
WPA Algorithm: TKIP

System Requirements
N/A

Package Contents
N/A

Regulations/Certifications
RFC768 UDP
RFC791 IP
RFC792 ICMP
RFC793 TCP
Channel Bandwidth: 20/40MHz (default)

Dimension (W x H x D)
111 x 56 x 47.7 mm

Weight
13 kg

Additional Features
DHCP Server: Support
System Tool: Upgrade, Reset to Factory Default, Login Password, System Log, Reboot
Shipping Notes
  • Free Standard Shipping on $100+ Orders to the USA.
  • Except Preorder products are shipped in 48 hours.
  • Delivery to the USA:
  1. Standard Shipping : 3-10 business days
  • If time is of the essence, please consider selecting expedited delivery for faster service.
Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy
SKU: 66776215827

Discover Niche Categories That Outsell

Top-Converting Item to Boost Your Average Order

4.3 ★★★★★
Based on 5 reviews
Sort
Highest Rating
Newest First
Oldest First
Product Reviews
N
Verified Purchase
Nate
Phoenix, US
★★★★★ 5
The coat of warmth
Size: Small, Color: Black
Love the simple style but very elegant. Fit perfectly, I'd say worth of buying, warm you up Good quality. Not too heavy. Good price as well.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on August 26, 2025
L
Verified Purchase
Linda Schmidt
Dallas, US
★★★★★ 5
My husband loves it!
Size: Large, Color: Black
My husband loves it! Likes the look and quality.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on January 22, 2026
B
Verified Purchase
Bri
Grantham, US
★★★★★ 5
Great style; unique; fits well.
Size: Medium, Color: Gray
Love the style and the fit. I get a lot of complements wearing this. With only three buttons, wearing this outdoors in the cold might not be practical. Other than that, I like it. I went back and ordered a second coat but in a different color.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on January 7, 2026
F
Verified Purchase
Fremy
Lake Worth, US
★★★★★ 4
Nice, mid-length trench coat for style and comfort...
Size: X-Large, Color: Black
I like this mid-length trench coat. The seams are good (on the one I got) and the style is perfect for the office, semi-formal occasions and all-around wear. The fit is good, and the only complaint I would have is the sleeves are a bit too short for my long arms.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on February 9, 2023
S
Verified Purchase
Sharon
Whiting, US
★★★★★ 3
It’s ok
Size: X-Large, Color: Gray
This jacket is OK. I bought it for my boyfriend because I really like the coat collar but once it got here. The front fits well but I think the back needs a little more tailoring because it kind of sticks out but he really liked it. He said he could put a heavy sweater up under it. That way he can get more ware out of it. It’s OK.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on July 21, 2024

recommand products